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Powerful tools in Excel
Not only will Excel add and subtract, but it can make words or sentences and
make workbooks with calculations easier to read.
Count vs. Counta vs. Countif
Count - Counts the number of cells that contain numbers and numbers within the
list of arguments. Use COUNT to get the number of entries in a number field in a
range or array of numbers.
Counta - Counts the number of cells that are not empty and the values within the
list of arguments. Use COUNTA to count the number of cells that contain data in
a range or array.
Countif - Counts the number of cells within a range that meet the given criteria.
Examples
Suppose A3:A6 contain "apples", "oranges", "peaches", "apples", respectively:
COUNTIF(A3:A6,"apples")

equals 2

Suppose B3:B6 contain 32, 54, 75, 86, respectively:
COUNTIF(B3:B6,">55") equals 2
Trim
Removes all spaces from text except for single spaces between words. Use
TRIM on text that you have received from another application that may have
irregular spacing. This is especially useful when doing text matching.
Example
TRIM(" First Quarter Earnings ") = "First Quarter Earnings"
Concatenation
Sometimes, a number is best placed within a sentence on a spreadsheet. To do
this, use the “&” symbol to add strings and numbers together.
Example:
•
•

In A1 Type 2
In A2 Type 2
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In A3 Type =A1+A2
In A4 Type =”The quantity” & A1 & “+” & A2 & “=” & A3

•
•

Ceiling, Floor
These functions make round up (ceiling) or down (floor) depending how they are
called.
Example
How many cars are needed if each car can fit 4 people and we have 23 people?
Example
How many dollars do we have if we have 235 pennies?
Today
Gives the current date. This field is updated every time the spreadsheet is
updated (like on load).
Lookup
A vector is a range of only one row or one column. The vector form of LOOKUP
looks in a one-row or one-column range (known as a vector) for a value and
returns a value from the same position in a second one-row or one-column
range. Use this form of the LOOKUP function when you want to specify the range
that contains the values you want to match.
Example

1
2
3
4
5
6
7
8

A
B
Frequency Color
4.14234 red
4.19342 orange
5.17234 yellow
5.77343 green
6.38987 blue
7.31342 violet

C

LOOKUP(4.91,A2:A7,B2:B7) equals "orange"
LOOKUP(5.00,A2:A7,B2:B7) equals "orange"
LOOKUP(7.66,A2:A7,B2:B7) equals "violet"
LOOKUP(7.66E-14,A2:A7,B2:B7) equals #N/A,

smallest value in the lookup_vector A2:A7
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because 7.66E-14 is less than the

Vlookup
Searches for a value in the leftmost column of a table, and then returns a value in
the same row from a column you specify in the table. Use VLOOKUP instead of
HLOOKUP when your comparison values are located in a column to the left of
the data you want to find.
Example

1
2
3
4
5
6
7
8
9
10
11
12

A
B
C
Air at 1 atm pressure
Density
Viscosity
Temp
(kg/cubic m)
(kg/m*s)*1E+05 (degrees C)
0.457
3.55
500
0.525
3.25
400
0.616
2.93
300
0.675
2.75
250
0.746
2.57
200
0.835
2.38
150
0.946
2.17
100
1.09
1.95
50
1.29
1.71
0

D

VLOOKUP (1, A4:C12, 1) equals 0.946
VLOOKUP (1, A4:C12, 2) equals 2.17
VLOOKUP (1, A4:C12, 3) equals 100
VLOOKUP (.746, A4:C12, 3) equals 200
VLOOKUP (0.1, A4:C12, 2) equals #N/A, because 0.1 is less than the smallest value in column A
VLOOKUP (2, A4:C12, 2) equals 1.71

Left, Right, Mid
Left
LEFT returns the first character or characters in a text string, based on the
number of characters you specify.
Right
RIGHT returns the last character or characters in a text string, based on the
number of characters you specify.
Mid
MID returns the characters from
the middle of a text string, given
a starting position and length.
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Referencing Cells in Excel
We are quite familiar with referencing particular cells in Excel. When we copy
formulas, the cell references change with the new cell location. What if we didn’t
want to change the location of the cell? We can tell Excel to use an absolute
reference. This is denoted by putting a $ in front of both the column and the row.
Example
Compound
Interest
$1,000.00
$1,050.00
$1,102.50
$1,157.63
$1,215.51
$1,276.28
$1,340.10
$1,407.10
$1,477.46
$1,551.33
$1,628.89
$1,710.34
$1,795.86

Now what happens if we want 5% and 6%?
$
$
$
$
$
$
$
$
$
$
$
$
$

5%
50.00
52.50
55.13
57.88
60.78
63.81
67.00
70.36
73.87
77.57
81.44
85.52
89.79

Copying the formula over creates a mess because it
is looking at the 5% interest column! To make sure
that it is only looking at the Money column, put a $ in
front of the column. Now the formula will always look
in the right place as the formula is being copied to
the right.

Subtotals
Returns a subtotal in a list or database. It is generally easier to create a list with
subtotals using the Subtotals command (Data menu). Once the subtotal list is
created, you can modify it by editing the SUBTOTAL function.
Example
Open ListSort.xls in Beyond the Basics of Excel
•
•

Add a subtotal to the list on bundles and trees
Use the filter function

Note:
SUBTOTAL will ignore any hidden rows that result from a list being filtered. This
is important when you want to subtotal only the visible data that results from a list
that you have filtered.
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Macros
Macros are simply small programs written in Visual Basic that do specific tasks.
These macros can be created or downloaded and incorporated into a
spreadsheet.
In the View Tab of the Ribbon, Click on the Macros dropdown and Record
New Macro
Gets to the macro menu
•
•
•

Macros… Alt+F8
Shows the macros in the workbook.
Record New Macro…
Allows a person to create macros even if you don’t know the language
Visual Basic Editor Alt+F11
This shows the language and commands used to create the macro

To Stop a Macro

Macro Window
Hello World
The first program customarily written by a new programmer is “Hello World!”.
This program simply prints out Hello World. To do this using Excel macros,
•

•

In the View Tab of the Ribbon, Click on the Macros dropdown and Record
New MacroNew Macro
o Name
o Shortcut (ctrl and/or shift)
o Store macro in…
o Description (help others)
Enter in these commands
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•
•
•
•

o Name – HelloWorld
o Shortcut – ctrl+w
o Store macro in… (This workbook)
o Description (Print out Hello World – First program)
Click OK
New Form comes up with a stop button
Type in Hello World! and click on the stop button.
Test it – in various places

Hello World (part 2)
It goes back to the same spot, regardless of where you start. To make it relative,
click on the red arrow right next to the stop button. Follow the steps above and
try again. Did it work?
Looking at the code
The commands that are used to create the Hello World should look like the
following:
Sub HelloWorld2()
'
' HelloWorld2 Macro
' Macro recorded 11/1/2003 by Don Bremer
'
' Keyboard Shortcut: Ctrl+w
'
ActiveCell.FormulaR1C1 = "Hello World"
ActiveCell.Offset(1, 0).Range("A1").Select
End Sub
The ‘ marks represent comments and are not read by the computer.
Structures of programming
There are actually 3 structures to any programming language. They are:
• Statement
• Loop
• Logical
To make a loop in a macro with a known number of times through, we can use
the for command. We can change the comands of the macro to read:
For i = 1 To 5
ActiveCell.FormulaR1C1 = "Hello World"
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ActiveCell.Offset(1, 0).Range("A1").Select
Next
This will write “Hello World” on the cell, move down one cell, and write “Hello
World” again. Try this….
Logicals will ask a question. Depending on the answer, it will do a set of
commands. Take for example the last “Hello World” example. Instead of having
it say “Hello World” all 5 times, what if we have it say “Goodbye Cruel World!” on
the last loop. We can do that using the conditional (or if) statement:
For i = 1 To 5
If i = 5 Then
ActiveCell.FormulaR1C1 = "Goodbye Cruel World!"
Else
ActiveCell.FormulaR1C1 = "Hello World"
End If
ActiveCell.Offset(1, 0).Range("A1").Select
Next
Sort Worksheets using Macros
In this exercise, we will create a macro from scratch. This macro can then be
called from another.
•
•
•

Start a new workbook
In the View Tab of the Ribbon, Click on the Macros dropdown and Record
New Macro
Type in the code below:

Sub SortSheets()
Dim SheetCount As Integer
Dim i As Integer
Dim j As Integer
SheetCount = Worksheets.Count
If SheetCount = 1 Then
Exit Sub
End if
For i = 1 To SheetCount - 1
For j = i + 1 To SheetCount
If Worksheets(j).Name < Worksheets(i).Name Then
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Worksheets(j).Move Before:=Worksheets(i)
End If
Next j
Next i

End Sub
•

Create another macro that calls this macro by writing:

Sub Caller()
' MsgBox shows something on the screen in a window
MsgBox ("Preparing to Sort Sheets")
' Our macro
SortSheets
MsgBox ("Sheets Sorted")
End Sub

Pivot Tables
A PivotTable report is an interactive table that you can use to quickly summarize
large amounts of data. You can rotate its rows and columns to see different
summaries of the source data, filter the data by displaying different pages, or
display the details for areas of interest You can start a Pivot table by opening the
Pivot Table toolbar and clicking on the wizard.
Example
•
•

Sorting Lists from class 2 of Excel
Northwind database in access

Breaking the screen into frames
Selecting the tabs on the top slider and the bottom slider will allow the user to
open up 4 different panes that can be in 4 separate sections of the worksheet.
Common Error Types
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Error
#NULL!
#DIV/0
#VALUE!

#REF!

#NAME?

#NUM!

#N/A

Description
The formula contains a null (probably as a reference). Is your
formula complete?
The formula contains a division by 0. Are two pieces the same
value? Is your formula correct?
A textual value of a cell or an incorrect argument has been used
in the calculation. While there are other possibilities for
receiving this error, these two are the most common.
The value in the referenced cell is no longer available in the
formula. The cells, rows, or columns may have been deleted
that were used in the formula.
A formula is not entered correctly. The defined name used may
not exist, has been deleted or misspelled, or the quotes around
text may have been omitted.
There is a problem with a number. Excel cannot interpret it
because it is too small or too big or may not exist. Check for
incorrect argument types in a function.
This can signify several problems, depending on the formula.
•
•
•

No value was available (as in a lookup function).
It is being used as a placeholder when data is not yet
available.
Charting features ignore this, so it is often used when you
are charting data. To leave the cells empty would distort
the chart, so use #N/A to prevent a 0 value.

Transpose (Matrices)
Say you have a column of numbers/letter and want them to become columns
themselves. You can do this by transposing the matrix.
•
•
•
•
•

Select the column
Copy to the clipboard
Go to the new location
Go to Paste Special…
Paste while checking the Transpose checkbox

Example
Abe
Ben
Carl
Dave
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Edward

Can become….
Abe

Ben

Carl

Dave

Edward

Breaking apart formulas
Remember the Quadratic Formula in Algebra?

has the solutions

Program this? Yick! It might be easier to break it apart to get the answer:
A1: a
A2: b
A3: c
Now break apart the formula:
A5: -A2
A6: ((A2^2)-(4*A1*A3))^0.5
(4*A1*A3))^0.5
A7: 2*A1
Answers:
A8: (A5-A6)/A7
A9: (A5+A6)/A7
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Text to Columns
Use this method if your names have a delimited format, such as "First_name
Last_name" (where the space between First_name and Last_name is the
delimiter) or "Last_name, First_name" (where the comma is the delimiter).

1. Select the range of data that you want to convert.
2. On the Data tab, in the Data Tools group, click Text to Columns.
3. In Step 1 of the
Convert Text to
Columns Wizard,
click Delimited, and
then click Next.
4. In Step 2, select the
Space check box,
and then clear the
other check boxes
under Delimiters.
5. Click Next.
6. In Step 3, click a column in the Data preview box, and then click Text under
Column data format.
Repeat this step for each column in the Data preview box.
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7. If you want to insert the separated content into the columns next to the full
name, click the icon to the right of the Destination box, and then select the
cell next to the first name in the list (B2, in this example).

8. Click the icon to the right of the Convert Text to Columns Wizard.
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Remove Duplicates
When you remove duplicate values, only the values in the range of cells or table
are affected. Any other values outside the range of cells or table are not altered
or moved.
Caution Because you are permanently deleting data, it's a good idea to copy
the original range of cells or table to another worksheet or workbook before
removing duplicate values.
1. Select the range of cells, or make sure that the active cell is in a table.
2. On the Data tab, in the Data Tools group, click Remove Duplicates.
3. Do one or more of the following:
 Under Columns, select
one
or more columns.
 To quickly select all
columns, click Select All.
 To quickly clear all columns, click Unselect All.
If the range of cells or table contains many columns and you want to only select a
few columns, you may find it easier to click Unselect All, and then under
Columns, select those columns.
4. Click OK.
A message is displayed indicating how many duplicate values were removed and
how many unique values remain, or if no duplicate values were removed.
5. Click OK.
Naming Ranges
A Named Range is way to describe your formulas. So you don't have to have this
in a cell:
= SUM(B2:B4)
You can replace the cell references between the round brackets. You replace
them with a descriptive name, all of your own. So you could have this, instead:
= SUM(Monthly_Totals)
Behind the Monthly_Totals, though, Excel is hiding the cell references. We'll see
how it works, now.
Open up Excel 2007, and create the spreadsheet below:
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Select the Monthly Totals from B2:B4 and where it says B2 on the formula bar,
type “Monthly_Totals”

Now you can refer to that range as Monthly_Totals, no matter how big it is.
= SUM(Monthly_Totals)
Grab Information from Web
1. Go to the Data Tab and select “From Web”
2. In the Browser that appears, maneuver to the web page you would like to
grab
3. When you put your cursor over a “table” of data, it will be outlined with a
yellow arrow next to it.
4. Click on the yellow arrow, it will turn into a green checkbox
5. Click on the import button on the lower right side of the new browser
6. Tell it where to place the
data
7. Click OK
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Statistics
Even though it seems that the makers of
Excel put the kitchen sink in and reasdy to
go – not everything is visible. There is
another statistical package that is an AddIn if you want to go even further.
Office Button->Add-Ins->Manage Excel
Add-ins (Go…)
Select on Analysis ToolPak and click OK.
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A new item appears under data called “Data Analysis”. When the item is
selected, it shows the different things you can do:

Moving Average example:
The following illustration shows a summary of Contoso Pharmaceutical's
inventory for their 10 best-selling products from last year. This report shows a
large variance in the ending inventory quantities from month to month, indicating
both shortages and stagnant product — neither of which is good for business.
With a few simple steps, you can use this information to manage your inventory
levels more precisely this year.
Prod_ID Aug Sep Oct Nov Dec Jan Feb Mar Apr May Jun Jul
1176
96 10 10
72 72 60 60
14
2
93 94 26
401
19 11
4
47 47 69 52
13 13
56 64 75
1482
78 11
7
46
5 30 30
19
9 100 90 74
1548
96 11
0
99 99 74 74
18
1
73 18 74
1406
48 13 65
99 99 46 46
16 16
94 33 58
1517
3 13 13
26 26 92 92
10
1
44 18 47
301
15 15 32
55 55 17
8
46
8
59 69 84
303
32 18 41
65 65 11 11
50
1
72 43 51
688
46 18
0 -20 26 75 75
15
1
23 99 49
786
43 18 65
94 92 85 85
35
3
82 91 23

The Moving Average analysis tool projects values in the forecast period, based
on the average value of the variable over a specific number of preceding periods.
A moving average provides trend information that a simple average of all
historical data would mask. This example uses the data for Contoso product
1176 to predict a target inventory level for the new fiscal year.
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1. On the Tools menu, click Data Analysis.
2. In the Data Analysis dialog box, click Moving Average, and then click OK.
3. The Moving Average dialog box opens.

4. In the Input Range box, enter a single row or column of data. This
example uses the row of data from product 1176 on the Contoso top-10
top
products report.
5. In the Interval box, enter the number of values that you want to include in
the moving average.
e. In this example, enter 3, the default interval.
NOTE The interval is the number of data points used to calculate the
moving average. The larger the interval, the smoother the moving average
line; the smaller the interval, the more the moving average is affected by
individual data point fluctuations.
6. In the Output Range box, enter the cell address where you want the
results to start.
7. Select the Chart Output check box to see a graph comparing the actual
and forecasted inventory levels.
8. Click OK.
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Linest
Returns statistics that describe a linear trend matching known data points, by
fitting a straight line using the least squares method.
The equation for the line is:
y = mx + b
Example 1
Take for example the linear regression of sales per month
Month
1
2
3
4
5
6

Sales
3100
4500
4400
5400
7500
8100

Answer: 1000
What is the sales on the 9th month?
Sales = 1000* 9 = 9000

Example 2 – Multiple Linear Regression (the world is not linear)
Suppose a commercial developer is considering purchasing a group of small
office buildings in an established business district.
The developer can use multiple linear regression analysis to estimate the value
of an office building in a given area based on the following variables.
VARIABLE

REFERS TO THE

y

Assessed value of the office building

x1

Floor space in square feet

x2

Number of offices

x3

Number of entrances

x4

Age of the office building in years
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This example assumes that a straight-line relationship exists between each
independent variable (x1, x2, x3, and x4) and the dependent variable (y), the
value of office buildings in the area.
The developer randomly chooses a sample of 11 office buildings from a possible
1,500 office buildings and obtains the following data. "Half an entrance" means
an entrance for deliveries only.
Floor space (x1)

Offices (x2)

Entrances (x3)

Age (x4)

Assessed value (y)

2310
2333
2356
2379
2402
2425
2448

2
2
3
3
2
4
2

2
2
1.5
2
3
2
1.5

20
12
33
43
53
23
99

142,000
144,000
151,000
150,000
139,000
169,000
126,000

2471
2494
2517
2540

2
3
4
2

2
3
4
3

34
23
55
22

142,900
163,000
169,000
149,000

Formula

=LINEST(E2:E12,A2:D12,TRUE,TRUE)
NOTE: The formula in the example must be entered as an array formula. After
copying the example to a blank worksheet, select the range A14:E18 starting
with the formula cell. Press F2, and then press CTRL+SHIFT+ENTER. If the
formula is not entered as an array formula, the single result is -234.2371645.
When entered as an array, the following regression statistics are returned. Use
this key to identify the statistic you want.

The multiple regression equation, y = m1*x1 + m2*x2 + m3*x3 + m4*x4 + b, can
now be obtained using the values from row 14:
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y = 27.64*x1 + 12,530*x2 + 2,553*x3 - 234.24*x4 + 52,318
The developer can now estimate the assessed value of an office building in the
same area that has 2,500 square feet, three offices, and two entrances and is 25
years old, by using the following equation:
y = 27.64*2500 + 12530*3 + 2553*2 - 234.24*25 + 52318 = $158,261
Or you can copy the following table to cell A21 of the example workbook.
FLOOR SPACE
(X1)
OFFICES (X2) ENTRANCES (X3)
AGE (X4)
ASSESSED VALUE (Y)
2500
3
2
25
52317.83051

Assessed Value Y
=D14*A22 + C14*B22 + B14*C22 + A14*D22 + E14
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