
Visio Premier  

 

Instructor:  Don Bremer 
 

 

 

 

 

 

 

 

 

 

 

 

Presented and co-sponsored by: 
 
 

               
 

11 East Superior Street, Suite 210 

Duluth, MN 55802 

218-726-7298 (main)  

888-387-4594 (toll free)  

www.umdced.com 

ced@umdced.com 

 

 



University of Minnesota Duluth – Visio Primer 

Page | 2 of 30 

 

 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

Copyright© 2015 University of Minnesota Duluth  

Center for Economic Development.  

All Rights Reserved. 

Reproduction of this printed material in whole or in part without permission is prohibited. 

Microsoft and Access are either registered trademarks or trademarks of Microsoft 

Corporation in the United States and/or other countries. 

The University of Minnesota Duluth is an equal opportunity employer and educator. 

The Mission of the University of Minnesota Duluth Center for Economic Development is to assist 
entrepreneurs and businesses to grow and succeed. 

 

The Minnesota Small Business Development Center program is funded in part through a Cooperative Agreement 

with the U.S. Small Business Administration, Minnesota Department of Employment and Economic Development 

and regional support partners.  All opinions, conclusions or recommendations expressed are those of the author(s) 

and do not necessarily reflect the program sponsors.  Programs are open to the public on a nondiscriminatory basis. 

Reasonable accommodations for persons with disabilities will be made if requested at least two weeks in advance.  

 

U:  20150203-125800 



University of Minnesota Duluth – Visio Primer 

Page | 3 of 30 

 

 
 

 
 

Contents 

Interface ........................................................................................................................................................ 4 

Creating a New Diagram ............................................................................................................................... 5 

Selecting Shapes ....................................................................................................................................... 5 

Positioning shapes with rulers and guides ................................................................................................ 6 

Resizing and repositioning shapes ........................................................................................................ 7 

Connecting Shapes with Lines ............................................................................................................... 8 

Using AutoConnect and Quick Shapes .................................................................................................... 10 

AutoAdd and AutoDelete ............................................................................................................................ 12 

Replacing shapes ..................................................................................................................................... 13 

Adding text to shapes ................................................................................................................................. 16 

Add Screen Tip ........................................................................................................................................ 18 

Using Shape Data ........................................................................................................................................ 19 

Inserting fields ......................................................................................................................................... 20 

Hyperlinks ................................................................................................................................................... 23 

Create your own objects and stencils ......................................................................................................... 24 

Printing large flowcharts ............................................................................................................................. 26 

Make your Visio drawing page fit your flowchart....................................................................................... 26 

Print a large flowchart onto multiple pieces of paper ............................................................................ 27 

Appendix A – Flowchart Shapes .................................................................................................................. 28 

 

  



University of Minnesota Duluth – Visio Primer 

Page | 4 of 30 

 

Interface 

From the Quick Start Guide by Microsoft: 

 

The Ribbon: 

 

Things you might be looking for: 
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Creating a New Diagram 

If Visio is not running, start it.  On either the New or startup page, double-click the Basic Diagram 

thumbnail.  Save the drawing as Basic Shapes. 

1. Drag a Rectangle shape onto the drawing page and position it toward the upper-left corner of 

the page. 

2. Drag a Circle shape onto the drawing page and position it to the right of the rectangle.  Before 

you release the mouse button to drop the circle, move it up and down on the page.  As you 

move the circle, a green, horizontal Dynamic Grid line appears when the circle is in certain 

positions relative to the rectangle. 

 

 

3. Use the Dynamic Grid to align the circle with the middle of the rectangle and drop it so the 

space between the shapes is approximately 1 inch. 

4. Click on the circle and drag it closer to the rectangle.  The Dynamic Grid centerline appears, and 

if you’ve located the circle at a certain distance from the rectangle, a second Dynamic Grid 

element appears.  When the distance between the two shapes matches the default spacing 

interval for this page, a double-headed arrow appears. 

5. Keep dropping items and experiment with the dynamic spacing 

 

 

 

 

Tip: You can change the default inter-shape spacing interval for a page: on the Home tab, in the Arrange 

group, click Position, and then click Spacing Options.  The Spacing Options dialog box that appears 

enables you to change the horizontal and vertical spacing intervals. 

Selecting Shapes 
There are two common ways to select shapes 

• Ctrl+Click the shape you want to select/deselect 
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• Create a bounding box around the shapes you want to select. 

A third way to select (unique to Visio) is the Lasso select. 

• Lasso Select (Home->Editing->Select) 

 

Positioning shapes with rulers and guides 
1. Create a New document 

2. Drag a Rectangle shape onto the page and position it about one fourth of the way down the 

page.  Drop it so the left end is at the left margin of the page 

3. Use the resize handle on the right end of the rectangle shape to stretch the right edge to the 

right margin. 

4. From the Basic Shapes stencil, drag a 5-Point Star shape onto the page and drop it above the 

left half of the rectangle. 

5. Drag a 5-Point Star shape onto the page bbelow the rectangle and observe that the Dynamic 

Grid does not help. 

6.  Position the cursor over the vertical ruler on the left side of the page and observe that the 

cursor changes to a double-headed arrow.  Click the ruler and drag into the middle of the 

drawing page. 

7. Drag the top star toward and over the guide and observe that you can glue the edges and center 

of the star shape to the guide. 
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8. Glue the center of the star to the guide 

9. Drag the bottom star and glue its center to the guide. 

Note: Using a guide bar isn’t the only way to precisely locate an object 

 

1. Use the Zoom slider at the bottom of the drawing page to set the zoom level to 100%.  Then 

position the drawing page so the upper-left corner is visible 

2. Drag an Octagon shape into the upper-left corner of the page; before releasing the mouse 

button, observe that there are dashed lines in both the horizontal and vertical rulers. 

 

 

 

 

 

 

 

 

 

 

Resizing and repositioning shapes 

1. Open the file Size and Position 

2. Click once (don’t double-click) to select a shape A. 

The white squares that appear on a selected shape are referred to as selection handles, resize 

handles, or just handles 

 

3. Drag the middle handle on the right edge of shape A to the right to increase the width of shape 

A.  Notice the green arrow under other shapes when the rectangle becomes a certain size. 

4. Continue to drag the right handle of shape A further to the right until the Dynamic Grid 

feedback informs you that shape A is now the same with as shape B. 

5. Click on shape B and with the top circle, rotate the shape 90 degrees. 
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6. Click once to select shape C and then try to rotate it.  You are not able to rotate it because that 

property has been locked for this shape. 

7. Click once to select shape D, which is a sub-process shape.  All of the usual handles are available, 

but there is a new style of control handle in the lower-left corner of the shape. 

  

  

  

  

  

 

8. Click once to select Shape E.  Then on the View tab, in the Show group, click the Task Panes 

button, and the click Size& Position to open the Size & Position window.  Position the new 

windows to the left of shape E. 

9. Click in the Width cell, type 2, and then press Enter. The width of the cell changes to reflect the 

new value. 

Connecting Shapes with Lines 

1. Open Basic Shapes B 

2. On the Home tab, in the Tools group, click the Line Tool. Notice 

that the cursor changes to a plus sing with a diagonal line to the 

lower right 

3. Point near any of the five shapes toward the top of the page.  

Notice that dark squares appear on the edges and in the center 

of the shapes.  These are connection points.  

4. Move the cursor near a connection point and notice that a green square appears.  The square 

indicates that you can click on it to glue on end of the line to the connection point. 

5. Click the connection point on the right end of the rectangle, drag to the connection point on the 

left edge of the circle, and then release the 

mouse button. 

6. Draw another line above the rectangle but do 

not glue either end to a shape. 
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7. In a blank area of the drawing page, draw a freeform line, but sure to end it at exactly the same 

point you started. 

So far these are connectors that do not bend.  But, if a dynamic connector is used, Visio automatically 

adds and removes bends in the line based on the relative positions of the shapes to which it is glued. 

1. Open Basic Shapes 2 

2. On the Home tab, in the Tools group, click the Connector button.  Notice that the pointer 

changes to a black arrow and there is an arrow with two right-angle bends below it. 

3. Drag from the connection point on the right center 

of the upper rectangle to the connection point on 

the left edge of the circle, and the release the 

mouse button, creating static glue between the 

two connection points.  

Just as in the preceding exercise, the line you’ve 

drawn shows green handles at its endpoints.  However, unlike the previous line, a dynamic 

connector has an arrowhead on its destination end by default. 

4. On the Home tab, in the Tools group, click the Pointer Tool.  You can also press Ctrl+1 for this. 

5. Drag the shape up a small distance and observe what happens. 

6. By default, the Right-Angle connector is selected.  But, it can be changed to any other type of 

connector.  
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Using AutoConnect and Quick Shapes 
1. Click the File tab, then New.  Click Categories, click Flowchart, and then double-click the Basic 

Flowchart thumbnail.  Save the new drawing as Quick Draw. 

2. Drag a Start/End shape into the upper-left corner of the drawing page. 

3. Drag Process and Decision shapes onto the page to create a drawing like the one shown. 

 

Notice that when you point to any shape on the page, blue AutoConnect arrows appear on the 

sides that are not yet connected to another shape. 

4. Point to the AutoConnect arrow on the right side of the start/end shape.  The Live Preview 

feature of Visio shows a dynamic connector linking the 

start/end to the process shape.  A Mini Toolbar 

containing four shapes also appears. 

5. Click the AutoConnect arrow to connect the shapes. 

6. Continue clicking the appropriate AutoConnect arrows 

until the diagram looks like the following graphic: 
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7. Point to the Decision shape until the AutoConnect arrows appear, click the AutoConnect arrow 

on the right of the decision shape, and then drag it to the lower of the two rectangles on the 

right side of the page.  As you drag, the screen will look like the following graphic on the left.  

When you release the mouse button, the shapes are connected, as shown on the right. 

 

 

8. To the right of the Page-1 name tab below the drawing page, click the Insert Page button.  Visio 

adds a new page called Page-2. 

9. Drag a Start/End shape into the upper-left corner of Page-2. 

10. Point to the AutoConnect arrow on the right side of the start/end shape. Live Preview shows 

two things in addition to the dynamic connector arrow: it displays a preview of the shape that is 

currently selected in the stencil, along with a Mini Toolbar containing four shapes. 

 

11. Click the Process shape in the Mini Toolbar to drop it on the page. 

12. Point to the process shape and use AutoConnect and the Quick Shapes Mini Toolbar to add a 

decision shape to its right. 

13. Point to the decision shape on the page and drop a process shape below it.  When you click a 

Quick Shape in the Mini Toolbar, Visio always adds a dynamic connector.  The diagram should 

look like below. 
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14. Drag a Process shape from the stencil and drop it to the right of the decision shape already on 

the page.  Then drop another Process shape below it.  Be sure to use the Dynamic Grid to ensure 

that the space of the new shapes is consistent with the existing shapes. 

  

  

  

  

  

  

  

  

  

15. Right-click anywhere on the drawing page.  On the Mini Toolbar, click the Connector Tool, and 

then use it to link the right end of the decision shape to the left end of the lower-right process 

shape. 

AutoAdd and AutoDelete 

When adding a shape using AutoAdd, Visio rearranges the existing drawing to make the new shape fit.  

Sometimes the changes it makes are minor; other times they are more significant. 

When deleting a shape that is linked to one other shape with a dynamic connector, AutoDelete 

automatically removes the now superfluous connector. 

 

 

1. With the drawing completed in the last exercise – drag a Subprocess shape from the stencil and 

position it on top of any existing dynamic connector. Both ends of the connector display large 

green squares that are visible through the semitransparent Subprocess shape.  Don’t release 

the mouse button yet! 

2. Drop the Subprocess shape on the connector below the Decision shape to make room for the 

new shape. 
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3. Drag a Subprocess shape from the stencil and drop it on the connector between the start/end 

shape and the first process box.  Visio makes more significant changes in order to accommodate 

the new shape and avoid the unconnected Process shape in the upper right. 

4. Select the Process shape at the very bottom of the diagram and then press the Delete key to 

remove the shape.  Visio deletes the selected shape and also removes the dynamic connector 

that was linked to the Process shape. 

 

Replacing shapes 
The cool thing about Visio is that it holds information about the shapes other than the shapes 

themselves.  This is out of the purview of this class, but switching out shapes can be quite useful! 

1. Start a new drawing 

2. Open the Road Shapes Stencil by going to: 

More Shapes -> Maps and Floor Plans -> Map -> Road Shapes 

 

 
 

 

3. Drag a 4-way shape and use the Dynamic Grid to drop it in the center of the drawing page.  

Leave the shape selected. 
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4. With the 4-way shape still selected, on the Home tab, in the Shape Styles group, click Line and 

then in the Standard Colors section of the color menu, click Red. 

5. Drag a Road square shape onto the page and flue on end to the right end of the 4-way shape.  

Then drag and glue a second Road square to the left of the 4-way shape. 

 
 

6. Drag two additional Road square shapes onto the page and glue them to the top and bottom of 

the 4-way shape. 

  

  

  

 

7. Click the unglued end of the Road square 

shape attached to the top of the 4-way 

shape and drag it up and to the right until 

it is aligned vertically.  Then, do the same 

to the bottom. 

 

 

 

 

 

8. In the Shapes window, click the Landmark 

Shapes stencil header (More Shapes -> 

Maps and Floor Plans -> Map -> 

Landmark Shapes) and drag a Barn into 

the upper-left quadrant of the roadmap. 

9. Drag a Gas station shape into the lower-

right quadrant of the map. 
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10. Click the Barn shape on the drawing page once to select it. 

11. On the Home tab, in the Editing group, click Change Shape, and then in the Change Shape 

menu, point to the Building 1 icon.   
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12. Right-click the 4-way shape on the drawing page to select it and then on the Mini Toolbar, click 

Change Shape 

13. Change the 4-way to a Cloverleaf interchange. 

 

  

  

  

  

  

  

  

 

 

 

 

 

Adding text to shapes 

Most diagrams are self-explanatory.  For those that are not, text can be added. 

1. Start a blank new document using the Basic Flowchart Shapes template. 

2. Add Start, Process, and Decision shapes as below: 

  

  

 

 

  

3. Press Ctrl+A to select all 

shapes.  Then on the Home tab, in the Font group, in the Font Size list, click 14 pt. 

4. Double-click the process shape to the right of the start shape, type Prepare expense report,and 

then click anywhere on the background of the page.  When you click outside the shape, notice 

that the the shape becomes taller. 

5. Double-click the start shape and type Start. 

6. Click once (don’t double-click) on the decision shape, press F2, type Amount > $1000, and then 

press F2 again. 
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Let’s create a Title for this! 

1. On the Home tab, in the Tools group, click the Text button.  The cursor changes to a plus 

sign with a page icon below it. 

2. Click in the upper-left corner of the drawing page and drag to create a text cox that is 

around 6 inches long.   

 

 

3. Type Sample Flowchart for Expense Reporting Processing. 

4. On the Home tab, in the Tools group, click the Pointer Tool button.  Visio closes the text box 

and returns to the previous zoom level. 

5. On the Home tab, in the Font group, click the Font Size arrow.  As you point to various gont 

sizes, notice that Visio provides a live preview of the results. 

6. Select 24 pt. as the new font size 

7. If the text wraps in the box, drag and increase the size of the box until the text fits well. 
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Add Screen Tip 
1. Create a New (Blank) document 

2. Open the (More Shapes -> Network -> 

Computers and Monitors) stencil. 

3. Drag a PC shape on to the page 

4. On the Insert tab, in the Text group, click 

the ScreenTip button to open the Shape 

ScreenTip dialog box 

 

5. Type I *need* a new PC in the dialog box 

and then click OK. 

6. Point to the PC and observe the pop-up 

text that you’ve created. 

 

 

7. Drag a Laptop shape from the Computers and Monitors stencil onto the page. 

8. With the laptop shape still selected, on the Review tab, in the Comments group, click the New 

Comment button. 

 

 

 

9. Type: This laptop contains Visio Professional 2013. 

10. Click anywhere on the background of the page to close the comment edit box. 

11. Point to the comment balloon but don’t click it, which causes Visio to display the word 

Comments but only for as long as you continue to point to the indicator 

12. Click once on the comment indicator to ciew the Visio display of the comment edit box. 
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13. Click in the Reply area of the edit box and type It also contains Office Professional 2013 

 

 

 
 

14. Click Enter and it will store the comment 

 

 

Using Shape Data 

A significant part of what gives Visio diagrams uniqueness and value is the data that resides inside 

Visio shapes.  Called shape data starting with Visio 2007, data fields were known as custom 

properties in previous versions of Visio 

 

1. Open a new, blank document 

2. Open the Network and Peripherals stencil. 

3. Drag in a Server, Printer and Fax. 

4. Click once on the server shape to select it. 
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5. On the View tab, in the Show group, click the Task Panes button, and then click Shape Data.  

The Shape Data window appears and displays the names and current values, if any, for data 

fields that are contained within the server shape. 

 

 

6. Click in the Asset Number field and type 6789-

001. 

7. Click in the Serial Number field, and type 13579. 

8. Click in the Network Name field and type FileServer-A32. 

9. Click once on the printer to select it.  Notice that the Shape Data window now shows the 

fields that are defined for the printer. 

10. Click in the Asset Number field and type 6449-001. 

11. Click in the Network Name field, and tyhpe HR-Printer6. 

12. Click once on the fax to select it.  Notice that there are fewer fields defined for the fax 

machine. 

13. Click in the Manufacturer field, and type Contoso. 

14. Click the Product Number field and type FX351. 

 

Inserting fields 
1. Click once on the server shape to select it. 

2. On the Insert tab, in the Text group, click the Field button.  The Field dialog box opens and 

displays eight categories of field data that can be inserted into a shape. 
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3. In the Category section of the Field dialog box, click Shape Data. The Shape Data fields for this 

shape appear in the Field name sectio
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4. Scroll down in the Field name section, click Network Name, and then click OK.  

The field you inserted appears under the server.  

5. Click once on the printer to select it and then repeat the steps to display the 

network name for the printer. 

6. Click once on the fax to select it and repeat the steps, but this time select Product Number. 
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Hyperlinks 

This is a great way to go to specific places (on the internet) to help complete a task.  The diagram 

can also link to places within a company’s network or even support files. 

1. Open the file HR Process Map. 

2. Click Advertise open job shape and then open the Hyperlinks dialog box. 

3. In the Hyperlinks dialog box, type in the following information in the text boxes. 

 

4. Click OK 

5. Now, when hovering over the shape, a new icon and tooltip will appear. 

 

 

6. This will also link to documents within the computer. 

7. On the Log Hiring Request, Select Hyperlink. 

8. Click on Browse, then Local File. 

9. Select on the All Files Filter. 
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10. Browse to a file in Basics of Word Processing and select it. 

11. Test it out using Ctrl+Click on the object. 

Create your own objects and stencils 

What happens when no one has created the shapes you want?  You create your own! 

1. Use the drawing tools to create a drawing  

2. Select the Pointer Tool from the Tools menu 

3. Create a Bounding box around the items to be made into a 

shape. 

4. Right click on the selected items and group them together 

5. For us to use this shape, we need to create a new stencil to 

place it on.  Go to the Developer tab and select New Stencil (US 

Units) 

6. A place appears to drop shapes on the Stencil location 

 

 

7. Once dropped, a new name will be created. 
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8. To change the name of the item, right click on the item and select Edit Master -> Master 

Properties. 

 

 

 

9. Change the name of the shape into something more useful and Click OK. 

10. These changes should then be reflected in the stencil  

11. Use the floppy disk to name and save the stencil. 
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Printing large flowcharts 

The easiest way to print out a flowchart that is larger than your printer paper is to print it onto 

multiple pieces of paper and then tape the pieces together. 

Before you start printing, however, it's important to make sure that the drawing page, as it appears in 

Visio, contains the entire flowchart. Any shapes that hang off the edge of the Visio drawing page will 

not print. You can see whether the drawing page is large enough for the flowchart by checking the 

preview on the Page Setup dialog box (Filemenu, Page Setup, Print Setup tab). 

 

1. A flowchart that is too large for the Visio drawing page. 

2. A flowchart that fits the Visio drawing page. 

Make your Visio drawing page fit your 
flowchart 

1. With your flowchart open, on the File menu click Page Setup. 

2. Click the Page Size tab. 

3. Under Page size click Size to fit drawing contents. 

To see how the flowchart will print, look at the Print Preview, which is on 

the File menu. The figure below shows a flowchart that prints on four pieces of letter-

sized paper. 
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Print a large flowchart onto multiple pieces of paper 

1. On the File menu, click Page Setup. 

2. On the Print Setup tab, in the Printer paper box, select the paper size you want if it 

isn't already selected. Don't click OK yet. 

3. On the Page Size tab, click Size to fit drawing contents. The preview now shows the 

difference between the new page and the printer paper. 

4. Click OK. 

5. On the File menu, click Print Preview to see how the flowchart will print. 

NOTE   If there are shaded margins between the pages, they mark areas that print on 

both pieces of paper so that when you assemble the pieces there are no gaps in the 

flowchart. 

6. After the drawing is printed, you can trim the margins, overlap the pages, and tape 

them together. 
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Appendix A – Flowchart Shapes 

• Terminator    Use this shape for the first and last step of your process. 

 

• Process    This shape represents a step in your process. 

 

• Predefined process    Use this shape for a set of steps that combine to create a sub-process that is 

defined elsewhere, often on another page of the same drawing. 

 

• Decision    This shape indicates a point where the outcome of a decision dictates the next step. There 

can be multiple outcomes, but often there are just two —yes and no. 

 

• Document    This shape represents a step that results in a document. 

 

• Data    This shape indicates that information is coming into the process from outside, or leaving the 

process. This shape can also be used to represent materials and is sometimes called an Input/Output 

shape. 

 



University of Minnesota Duluth – Visio Primer 

Page | 29 of 30 

 

• Stored data    Use this shape for a step that results in information being stored. 

 

• On-page reference    This small circle indicates that the next (or previous) step is somewhere else on 

the drawing. This is particularly useful for large flowcharts where you would otherwise have to use a 

long connector, which can be hard to follow. 

 

• Off-page reference    When you drop this shape onto your drawing page, a dialog box opens where 

you can create a set of hyperlinks between two pages of a flowchart or between a sub-process shape 

and a separate flowchart page that shows the steps in that sub-process. 

 

Dynamic connector    This connector draws a path around shapes it encounters. 

 

• Annotation     This bracketed text box adjusts to accommodate the amount of text you type. You can 

set the width by dragging the sides of the shape. Like the Auto-height box shape, this shape doesn't 

represent a step in a process. Use this to add comments about your flowchart shapes. 

 

• Manual input    This is a step where a person provides information to the process. 
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• Manual operation    This is a step that must be performed by a person. 

 

• Internal storage    This shape represents information stored on a computer. 

 

• Direct data    This shape represents information stored so that any single record can be accessed 

directly. This represents how a computer hard-drive stores data. 

 

• Sequential data    This shape represents information stored in sequence, such ad data on a magnetic 

tape. When data is stored in sequence, it must be retrieved in sequence. For example, in order to 

access record 7 you would have to first go through records 1 through 6. 

 

 


